Rapiro Forum

Ask questions and share your thoughts about Rapiro.

This website was originally operationg as a forum, which has been converted into a static site. /

JavaScript controlled Rapiro

Dear Rapiro Fans, I have written JavaScript (Node.js) codes that can control a Rapiro from Raspberry Pi 3 B which is built in the Rapiro...
0 comments posted by mkoku on 2017-01-16 17:33

Firmata経由でA6, A7ピンのアナログ入力ができずにいます

こんにちは。 Rapiroのメイン基板にStandardFirmataを書き込んで、Raspberry Pi から Node.js (johnny-five) で制御して遊んでいます。この度、距離センサ(GP2Y0A21YK)を搭載して、メイン基板の拡張ピンのA6(または...
1 comments posted by mkoku comment from mkoku on 2017-01-21 16:01

problems adjusting servos with power adapter

Hi - I have just recevived a Rapiro and is trying to assembly one I got to the part where I connected the servos with the board and is tr...
1 comments posted by Mr.Robot comment from Mr.Robot on 2016-11-12 19:54

Rapiro Power Problem Solved

I’ve been always annoyed by the unstable power supply chain and finally perhaps found a stable solution. DC input: 12V5A AC-DC convertor...
9 comments posted by llacarte comment from llacarte on 2016-11-07 14:14

Disable Feet

Hello, is it possible to disable feet control by software? I mean, imagine I don't want my Rapiro to walk and I don't want to disassemble...
0 comments posted by icordoba on 2016-09-07 20:43

Both USB power and Rapiro Power in a Raspberry PI (Model 3). Any problem?

Hello, I am developing a solution with Rapiro and Raspberry PI 3 and once it is connected I don't want to have Rapiro on all the time I ...
0 comments posted by icordoba on 2016-09-05 18:37

How to connect Rapiro to a Pi3 correctly?

How to connect Rapiro to a Pi3 correctly? I just got my rapiro BUT can't get it to work. I saw a cable that connect between rapiro board...
1 comments posted by ArtkranTemritikulchai comment from phoenixln on 2016-08-28 15:26

difficulty moving forward

My rapiro has difficulty moving forward. It lifts its feet but seems to stay mostly on spot when executing command #M1, #M2, #M3 and #M4...
0 comments posted by phoenixln on 2016-08-28 15:19

Pi3 And Rapiro, minicom issues?

Just got my rpi3 up and running, but running any minicom commands gets me this screen Welcome to minicom 2.7 OPTIONS: I18n Compiled on...
1 comments posted by mgudesblatart comment from mgudesblatart on 2016-07-27 12:30

Testing Pi 3 with Rapiro

It's no goal. $ sudo minicom -b 57600 -o -D /dev/ttyAMA0 "#M0" Yields no action. It seems to be related to the issue with the sdio dr...
5 comments posted by luzhuomi comment from mgudesblatart on 2016-07-27 12:29

AC power supply to use as external power source for RasPi 3

Hi, I live in Japan, and have a RAPIRO set up with a Raspberry Pi (1st) Model B+ and have got it to work. I upgraded the RasPi to the la...
1 comments posted by tuuyaa comment from tuuyaa on 2016-06-23 16:54

「stk500_getsync(): not in sync: resp=0x00」のエラー

何度かサンプルのスケッチの書き込み、及び動作は確認していたのですが、 とたんに動かなくなりました。 スケッチを書き込むことも、コマンドを送信することもできません。 考えられるシリアルポートの間違いやドライバのインストール、ポートのビットを確認、調整していますが、 それでも...
0 comments posted by nakanishi.bbb on 2016-05-29 14:35

Eyes don't stay on

Hi, I have some trouble installing the eyes. The screw does not stay on and the eyes keep falling off. Anyone has similar issues and kn...
0 comments posted by tlchiam on 2016-04-16 11:42

Rapiro UI by Bottle + HTML5

Rapiro UI by Bottle + HTML5 Version:20141206 Brief: A bottle framework + HTML5 based user interface to control Rapiro. I tried ...
1 comments posted by llacarte comment from mgudesblatart on 2016-02-11 14:42


Does any EMAX ES3103 will work as a large servo, or it needs to be the "customized" one? what exactly is the customization about? Thank you
0 comments posted by JavierSing on 2016-02-08 00:11


2 comments posted by oqoq comment from oqoq on 2016-02-04 09:57


2 comments posted by oqoq comment from oqoq on 2016-02-04 09:46

Help! TR1 transistor broken!

Hello, I found the TR1 transistor was broken on my board. I want to replace it by myself, but I cannot find its model number. Could you t...
2 comments posted by Li-ChiehSu comment from Li-ChiehSu on 2016-02-03 00:06


Hi, does anyone know where can i find the exact measures of the rapiro board (arduino compatible)? or the pcb design? Thank you
1 comments posted by JavierSing comment from JavierSing on 2016-02-02 01:51

LEDs work, servos wont run.

So. I may have fried my board? I'm not sure. I switched from using batteries to a 12V 5A AC/DC power adapter. After this none of the ser...
0 comments posted by mgudesblatart on 2016-01-24 03:45