Setting up communication between my Edison and Rapiro


I have managed to setup my Rapiro almost instantly (I Have to say that you created a really great product and even greater documentation ... thanks for that). Now having an Intel Edison lying around, I also got my hands on the Edison board for Rapiro ( and setup everything so now my Rapiro is operational and my Edison is available via Wifi connection.

I should mention, that I have never worked with Adruino, Raspberry PI and only played around with the Edisons OS and never had it connected to anything.

Now my next step was to login to my Edison (via SSH) and send some commands form Edison to Rapiros Adruino. Unfortunately this is where I'm stuck. I was planning on doing something like "screen /dev/ttyWhatever" and send some commands. Unfortunately this didn't work. So I do have a few questions now :-)

1. As far as I understood the 6 pin connection to the PI or Edison board contains the power supply as well as an UART Serial connection --> Is that correct?

2. So there is this one real UART Serial port and a virtual one which is available using the USB connection --> Is that correct?

3. The sketch available on the Rapriro site uses "Serial" so it seems there is only one serial port (I tried Serial1, Serial2, ... but that doesn't compile) How does Rapiros reference sketch decide from which serial connection the commands are coming? Or does "available" return true as soon as one of the two ports has something ... that doesn't sound good.

4. Assuming on the Adruino side everything is setup correctly with a sketch that would receive and interpret my commands, do I explicitly have to compile, configure anything on the Edison side? If yes, I would be glad to get some pointers to what exactly. Do I need to do something like configuring the GPIOs as described here ?

Would be really happy if you could give me a little push in the right direction :-)


posted by christofer.dutz on 2015-12-24 02:10

Ok so it turned out to be a lot easier than I thought. I have no idea, why it didn't work yesterday, but today I did a little more research on the Edisons com ports and came to the conclusion that "/dev/ttyMFD1" must be the correct one. So I just tried again:
screen /dev/ttyMFD1 57600 -L
I actually got the empty screen and entered:
and my little robot started walking :-)

So in the end I should simply stop thinking to much ... but I still don't quite understand how the com ports are setup on the Arduino. Is the internal one connecting it to the Edison disabled as soon as the USB connection is in place? If yes then this was probably the reason for my problems yesterday :-)

posted by christofer.dutz on 2015-12-24 22:07

Read Terms of Service upon submitting. 投稿する前に利用規約をお読みください。