Initial Installation

I mounted the distance sensor in rapiro like the instructions here:

Now when I turned on nothing happened then I uploaded the
I uploaded in the COM5 detected by Windows 7 like "Arduino Uno" and nothing happens also
and I made this tests with different power supplies:

With the power supply suggested in the site:

6V 4A
WSU060-4000 Mouser Electronics (Mouser Part #:553-WSU060-4000)(confirmed without a RPi)

The position of rapiro is ugly like contortionist:

Here emits a sound like click, click forever and ever the servos and stucked in that position shown in the picture.But the servos are not glued you can mtouch or move with your hands.

With a power supply of 12 V 10A:

The position is better when you turn on more aligned:

Here emits a buzzing sound and here the servos are totally glued there.

In both cases I have the power supply conected and via USB 3 rapiro in my computer at same time.
The computer detect perfect, arduino the same and the eyes of rapiro are blue. When I click upload in Arduino allok write the robot turned off for a second and then automatic is turned again but does nothing I tried to adjust the:

int trim[MAXSN] = { -5, // Head yaw
10, // Waist yaw
0, // R Sholder roll
0, // R Sholder pitch
0, // R Hand grip
0, // L Sholder roll
0, // L Sholder pitch
0, // L Hand grip
0, // R Foot yaw
0, // R Foot pitch
0, // L Foot yaw
0}; // L Foot pitch

I put there data like you see and nothing happens with both power supplies.
If someone can help me to know what is happening or why is not working rapiro or
what can I do to solve?
Of course I never tested before rapiro before mount the distance sensor.
Thank you

posted by coerrace on 2014-04-30 03:44

Sorry I think I might not fully understand what your problem is. If you think something wrong, what you should do is remove the distance sensor. You must follow the assembly manual first. You might change the initial position of servo motors, after you did step 53 on the assembly manual.

step 53

posted by on 2014-04-30 18:23

Finally I could detect the problem, I assembled fine, then not was an assembling issue. I write here what worked for me and maybe could work for any other who can have troubles like me:

1.-With the power supply suggested in the site:6V 4A WSU060-4000 Mouser Electronics (Mouser Part #:553-WSU060-4000)(confirmed without a RPi) NOT WORK AT ALL I bought that power supply in mouser electronics directly and not work, not support the servos .
2.-My power supply with 12V 10A works perfect like a charm.
3.-The problem who made the Arduino software not send good the commands or .ino files to rapiro and cause not move the servos was my port USB 3 in my Laptop I changed rapiro to one USB port 2 and worked like a charm.

Now I have a question to test the distance sensor I have installed but I need to know if it is working good. Like the site of mounting distance sensor help say I do:
If I give the #A6 command the terminal shows me:
The distance sensor is working with that result in the terminal or I need to see other kind of value?
Thank you

posted by coerrace on 2014-05-01 03:27

I am grad to hear that you made it. But I'm sorry for the WSU060-4000. It worked for us in Japan. I can't figure out why now.

#A6V437 is OK. V437 is correct response. 437 is the value that sensor generates. The value may take 0 to 1023.

posted by on 2014-05-01 12:30

Hi, have you got any errors when you upload Oga's firmware ? I got some trouble on Oga's code: #include , there's no pgspace.h ? any advice ? Thanks

posted by JoeYang on 2018-02-26 18:25

@coerrace , could you tell me what brand of your "12V 10A" worked perfectly with Rapiro?


posted by jooooooooo on 2018-04-30 14:53

Read Terms of Service upon submitting. 投稿する前に利用規約をお読みください。